PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Two ajax spinners on form in fancybox modal

  1. Hi.
    I have a page, with a hidden form, that loads in a Fancybox modal window. When I submit the ajax form, two spinner icons are shown.

    I read this previous forum thread, but no answer was posted:
    http://www.gravityhelp.com/forums/topic/using-ajax-with-contact-form-in-modal-window-getting-2-spinners

    Unfortunately, I cannot link to my site, but the issue is exactly the same as the one posted in that thread.

    Posted 8 years ago on Wednesday June 27, 2012 | Permalink
  2. Hi forum masters!

    Is there no help on this topic? Is it because the site is not live yet?

    Cordially
    Vayu

    Posted 7 years ago on Wednesday July 11, 2012 | Permalink
  3. It will be difficult to troubleshoot without being able to see your form. Please post a link when it is live and we can view it online. Thanks.

    Posted 7 years ago on Wednesday July 11, 2012 | Permalink
  4. Alright, thanks, will do. :-)

    Posted 7 years ago on Wednesday July 11, 2012 | Permalink
  5. Thanks Vayu.

    Posted 7 years ago on Wednesday July 11, 2012 | Permalink
  6. I'm having the same issue (jQuery UI tabs is causing the duplicated script/spinner) - is there a solution for this?

    Posted 7 years ago on Thursday August 23, 2012 | Permalink
  7. The solution is to fix the jQuery conflict. Can you post a link to your site where we can see this in action?

    Posted 7 years ago on Friday August 24, 2012 | Permalink
  8. Sure - the site is still under development, but I made a uid/pwd for Gravity to preview (there is nothing sensitive on the site).

    http://wpd.visualcrossing.com/about/#contact_us
    u: gravity
    p: gravity!

    If you hit the Submit button, you can see the double spinners (only the first time - subsequent submits only show one spinner).

    I'm using the jQuery UI plugin for WP which generates the tab markup & js via a shortcode (i.e. after the page loads the unstyled content) - so I'm guessing it is causing some script hook to fire twice. The form is a plain gform, nothing special.

    Thanks for the assist!

    Posted 7 years ago on Friday August 24, 2012 | Permalink
  9. I had a similar problem, struggled for hours only to discover that I used the GF shortcode twice on the page.

    Posted 7 years ago on Saturday August 25, 2012 | Permalink
  10. @webstuff, thanks for sharing that.

    Posted 7 years ago on Saturday August 25, 2012 | Permalink
  11. @Twig, if you disable the jQuery UI plugin for WP, does the double spinner still occur? Also, if you embed the form by itself in a WordPress page (rather than the tabbed interface), is there just a single spinner? If you embed the form in your tabbed interface without AJAX, is there still a single spinner?

    Posted 7 years ago on Saturday August 25, 2012 | Permalink
  12. Same problem here. No luck with deregistering any of the jquery ui interface. Always get 2 spinners on the first submission. If there is an error on the form and you have to resubmit only 1 spinner shows.

    Posted 7 years ago on Friday September 7, 2012 | Permalink