PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Upgrade to 1.7.2 - cannot edit form fields

  1. I see a few other similar posts - but want to add my experience here too to help the developers, as well as users of GF that may be having the same issue.

    First the stats: I'm running WordPress 3.5.1, on a PC (Win7). The issue occurred in both Chrome (current: 26.0.1410.64) and Firefox (20.0.1). I did not try it in other browsers.

    I have been working in GF extensively for a week. This morning I upgraded to 1.7.2, and immediately after upgrading, I was no longer able to edit my form fields. I can go into Forms, select my form, and reach the edit form field (can also see form settings, notifications, etc.) -- but when I attempt to edit any of the fields nothing happens. Typically when I would hover over the form field it would highlight and then I could see the Edit and other buttons, but this stopped happening. I tried to click the fields - nothing happened. Also, the sidebars with "standard fields" "advanced fields" etc - would not work. Meaning, I click, nothing happened. Could not collapse those boxes, either (they defaulted to all being open).

    I went into GF settings and turned on no-conflict, and everything started to work again, which is great, but it seems to me there is a big problem somewhere if that was necessary to do, so I wanted to let you know.

    Posted 10 years ago on Tuesday April 30, 2013 | Permalink
  2. David Peralty

    What our No Conflict mode does is unregister all JavaScript on our admin pages and then adds the needed ones back in. The issues you were experiencing were likely due to a third party (theme/plugin) outputting JavaScript on our administration pages that were removed once you turned no-conflict on.

    Posted 10 years ago on Tuesday April 30, 2013 | Permalink
  3. UPDATE: after restarting nginx everything is working. I hate not being able to put my finger on the problem... and I saw a lot of people have similar symptoms...

    I have a similar issue where I'm unable to update/add fields... or edit the form settings. I enabled No Conflict and it has not affect. Also, despite being on version 1.7.2 the wordpress network admin continues to say there is an update available.

    Posted 10 years ago on Tuesday April 30, 2013 | Permalink
  4. David Peralty

    Sounds like server caching or something strange. I'm not entirely sure, and don't know where the issue could have come from either. Glad you got it sorted though.

    Posted 10 years ago on Tuesday April 30, 2013 | Permalink
  5. Hi all – I’ve having the exact same problem as thewebscaper. I’ve updated GF to 1.7.2 and no-conflict is ‘on’ but I can’t edit my form at all. I can view the form and move around the sidebar fields but struggling to find a way where I can edit it.

    Any assistance is appreciated.

    Posted 10 years ago on Wednesday May 1, 2013 | Permalink
  6. Resolved it - there is a conflict with a slideshow plugin. Does anyone know of a slideshow plugin that works alongside GF?

    Posted 10 years ago on Wednesday May 1, 2013 | Permalink
  7. David Peralty

    Thanks for letting us know douglas. Look for one that is already updated for WordPress 3.6 and you might have your best chance having it work. All my best!

    Posted 10 years ago on Wednesday May 1, 2013 | Permalink
  8. My problem is exactly the same as "thewebscaper". I have been working on this problem ever since the upgrade to Gform V. 1.7.2. The problem is: After adding probably 4 or 5 form fields and updating the form just fine suddenly the "Update Form" hangs when "uploading" at around 90%. I have tried everything in this tread and everything that I can find throughout the Gravity Support Forums, (i.e. removing all plugins and child theme) and this problem continues to persist.

    I would be happy with instructions on how to remove Gravity V 1.7.2 and reload a previous working version, but it appears there is no "go back" ability. I don't dare upgrade my other sites and hope my client sites do not click the "upgrade" until I can find a resolution to this. Please.

    My Stats: Windows PC (Win 7), Chrome V 26.0.1410.64 m, Wordpress V 3.5.1, Base Theme Twenty Twelve V 1.1.

    Thank You for any assistance you can provide.

    NEW INFORMATION: I have since tried (again) by removing my current theme and setting it to the TwentyTen Theme (as instructed) and deactivating all plugins except Gravity Forms. I then created a New Form and ran into the same problem (update hanging at 90%) after adding 8 form fields. Note the form I am trying to build is a multi-page form with 1 form field on each page and a total of 12 pages.

    Posted 10 years ago on Saturday May 4, 2013 | Permalink
  9. I have the same problem. After I've updated the GF plugin, I'm not able to edit anything. And the City field turns into the ZIP/Postcode field. I've removed the 1.7.2 update and put the previous one back into its place. I'm managing about 20 client sites, and this means 20 different configurations (themes, plugins, you name it). So I'm not going to figure out what is conflicting with the GF plugin. Any change that there's a version of GF that's working?
    Henk van der Duim

    Posted 10 years ago on Sunday May 5, 2013 | Permalink
  10. OK... So I have attempted one more variation and concluded that maybe it is a paging error I am experiencing. I tested my theory by using a different hosted site running WordPress V 3.5.1 and the TwentyTen Theme V 1.5 and I loaded GravityForms V (the oldest version that I had) and attempted to create a multi-page form just as in my example before listed in this thread.

    When I got up to page 7, all was working fine, but when I added pages to the form beyond that, the update would hang and never complete beyond (90+%). Is there a limit to the number of pages we can have in a Gravity Form?

    Thank you for your support. ...Howard

    Posted 10 years ago on Sunday May 5, 2013 | Permalink
  11. I had the same problem and cleared the cache. After clearing the cache, I was able to edit the form.

    As for the hanging, the website I am working on was hanging. After deleting the new form and it's remnants, the hanging stopped.

    The other problem I experienced was that certain works contained links. Very bizarre! After deleting the form, the unwanted links disappeared.

    I hope this helps!


    Posted 10 years ago on Sunday May 5, 2013 | Permalink
  12. Hi all. I just upgraded to 1.7.2 and my issue is that I cannot edit any PRICING fields... other fields are no problem, but none of the pricing fields allow me to edit them once added to the form.

    anyone else had that issue?

    Posted 10 years ago on Sunday May 5, 2013 | Permalink
  13. In my case, the conflict arises when using the GF STRIPE plugin and GF... there must be something going on with those 2 plugins and the most recent GF update.

    For the record, the Stripe plugin automatically updates itself when you update GF.... hopefully this is an easy fix - STRIPE is awesome!


    Posted 10 years ago on Sunday May 5, 2013 | Permalink