PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Uploaded Files with Incorrect Links when using encoding in filename

  1. I have a form created in Gravity Forms with a file upload for a CV. Most of the time this works great, and I can click on the link in the backend or in the notification email to download the file. For some files that are uploaded with encoding for spaces, the link takes me to a filepath like follows:

    eg. website.com/wp-content/uploads/gravity_forms/1-31a61026fe30a7630418b37f2537a40b/2012/07/Ali%2520Hadi%2520resume%5B1%5D11.doc

    However this returns a 404 error.

    When I navigate to the file in an FTP browser, I can verify the filename is Ali%2520Hadi%2520resume%5B1%5D11.doc which matches the filename in the URL, however when I grab the path to the file from my FTP browser, I get:

    website.com/wp-content/uploads/gravity_forms/1-31a61026fe30a7630418b37f2537a40b/2012/07/Ali%252520Hadi%252520resume%255B1%255D11.doc

    Notice the extra 25 in 2520 to make it 252520. This link actually works, however Gravity Forms isn't using this link.

    Is this a bug with a system or something that can be easily corrected with an .htaccess file?

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  2. Interestingly enough another user posted earlier with a similar issue:
    http://www.gravityhelp.com/forums/topic/file-upload-saving-special-characters-as-urlencoded#post-66678

    However, as you'll see in my post - I had a different result. I'm thinking this is a host setting of some kind.

    Update - looks like the other user was running an old WP install - are you running the most current versions of WP and GF?

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  3. Both my Wordpress and Gravity Forms are using the latest version.

    Do you have any idea what host setting could be causing this? Something in the php.ini or apache.conf?

    Posted 7 years ago on Monday July 23, 2012 | Permalink
  4. David Peralty
    Administrator

    Yeah, something is re-encoding URLs, but I'm not sure where to point you currently. You might want to talk to your web host and see if he has something turned on regarding URL encoding.

    Posted 7 years ago on Monday July 23, 2012 | Permalink
  5. @Manu Did you ever solve this issue? I'm currently experiencing this on a WAMP setup.

    Posted 6 years ago on Monday January 21, 2013 | Permalink
  6. @tropixel, you already added to a topic here with the same question and more information:

    http://www.gravityhelp.com/forums/topic/attachement-file-with-accent#post-124767

    So I will close this topic so we don't duplicate any effort.

    Posted 6 years ago on Monday January 28, 2013 | Permalink

This topic has been resolved and has been closed to new replies.