PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

URL redirect after submission problem with MAMP

  1. Hi,
    I'm using MAMP to develop a site. I want the redirect after submission url to be:
    http://localhost:8888/mypage
    What happens is I get the following url instead:
    http://localhost/mypage

    The url strips out the :8888 and the page won't load.
    This makes it harder for me to develop locally.
    Can you advise?

    Posted 10 years ago on Friday January 13, 2012 | Permalink
  2. I am currently having the same issue. Any ideas would be greatly appreciated. Thanks.

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  3. Could not seem to change my ports to the default ports for Apache and MySQL as suggested on the MAMP forums. But got the redirect to work by entering (using your example) just "mypage" instead of "http://localhost:8888/mypage" in the Redirect URL field. It even works with a "Pass Field Data Via Query String" option.

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  4. Interesting!

    I tried your solution, it got me back into my wordpress site - but it put an extra ":/" in so I got a 404 error message. i.e.:

    Instead of "http://localhost:8888/mypage" it redirected me to "http://localhost:8888/:/mypage" which resulted in a 404!

    Puzzling!

    Posted 10 years ago on Wednesday January 18, 2012 | Permalink
  5. So I did do one other thing.

    I went into my System Preferences on my mac and then Sharing. I deselected Web Sharing as a lot of MAMP posts I saw on forums said MAMP does not always play nice with the Apple Web Server that runs on your machine. I deselected everything in fact, but not sure if that matters, but that might help if just deselecting Web Sharing does not work for you.

    That was maybe it, because I have tried
    mypage
    mypage/
    /mypage/

    And they all worked.

    "http://localhost:8888/mypage" still does not however.

    Posted 10 years ago on Friday January 20, 2012 | Permalink
  6. The whole problem came back! And through further research, I found out extra white space and lines in my functions.php file for the theme was causing problems. Check the MAMP php log.

    Posted 10 years ago on Wednesday January 25, 2012 | Permalink