PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

User emails with periods not recorded

  1. dipwick
    Member

    Hello,
    I have noticed that when users' email addresses include periods in the name (eg. john.smith@... as opposed to johnsmith@...) they are not recorded properly in the resulting admin notification email and the Form entry; all that is displayed is the text before the period, eg:

    Email:
    john.

    I am using the PayPal standard add-on and can verify that the full email is recorded by PayPal.

    This has happened to a few users to it's safe to say that it's not an issue of the users mistyping their email addresses.

    Any thoughts? I haven't found this exact issue elsewhere in the forums.

    Posted 6 years ago on Tuesday January 22, 2013 | Permalink
  2. Can you post a link to the page on your site where we can see the form do this?

    And, if I were to use an email with a period in it, you're saying it would be recorded in the entry incorrectly and thus in the admin notification incorrect as well.

    That is not my experience. I can use email address with a + or a period in them and they are preserved in the entry and in the admin notification. It's possible something on your site is doing this. Are you using any custom code with gform_pre_submission or gform_pre_submission_filter?

    Please check for theme and plugin conflicts by following these instructions http://rkt.gs/testing

    Posted 6 years ago on Monday January 28, 2013 | Permalink