PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Users getting kicked back to page 1, losing entries

  1. schindlerchris

    Hey folks— we've got a multi-page form that we've been using for about 7 months now. It's been working fine up until a couple weeks ago (can't recall if it started right after an update or what). We've gotten 10-20 complaints that once they get past page 2 or 3 (it doesn't seem to be the same page for everyone) they get kicked back to page 1 and all their entries are lost.

    I haven't been able to speak to the users directly, but here a couple of complaints that have been recorded:

    "The system will not let me continue past the 2nd page of questions. It continues to take me to step number one upon clicking the "next" button. I have tried this 5 different times."

    "I’ve now gone through the survey twice, and both times I hit Next on step 3 and I get sent back to the first page, and all of the answers are removed"

    I've tested it myself in Firefox on a Mac and in IE 8 on PC and it works fine for me. I thought it might be a timing-out issue (although I don't even know if that's possible) so I let it sit for a couple of hours before I clicked Next... it still worked fine.

    I've done no customization to the form, but it is on a password protected Wordpress page, if that matters.

    Any ideas? Thanks.

    Posted 12 years ago on Thursday December 15, 2011 | Permalink
  2. Hello Chris,
    The target page number is set into a hidden field at the time users click the submit button, so timeouts won't be the reason to this problem.
    What is interesting is that they are losing their answers. That tells me that the form is not being properly posted. We have had a few other users with a similar problem, and it ended up being web-server related issues with permalinks. The difference is that your problem is not consistent, which makes it even harder to troubleshoot. We would need to replicate the issue to be able to see what is causing it.
    Being under a password protected page should not matter, but it could be the cause of the problem.
    One suggestion that I have (and I am not sure if this is a viable solution for you), is to enable AJAX for this form. AJAX submissions are slightly different than regular submissions and it might get around this problem.

    Posted 12 years ago on Thursday December 15, 2011 | Permalink
  3. schindlerchris

    Thanks Alex, I've enabled AJAX so we'll see if that fixes it. Unfortunately I can't figure out how to replicate the issue, so for now I'll just have to wait and see if the complaints stop.

    Posted 12 years ago on Thursday December 15, 2011 | Permalink