PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Using avgrund.js for modal windows

  1. 1ternet
    Member

    Hi !

    I'm using the excellent Gravity Forms for a client. I need to open some of my forms in modal windows, and for many reasons we choose to use avgrund.js for modals.

    I've read many posts everywhere on how to open a form in a modal using fancybox & colorbox, thus none of them helped me.

    Avgrund doesn't work like fancybox : it needs to have the modal's content as a 'template" parameter value, and I could'nt get it to work using gravity forms function call or playing shortcode. I tried to call the form before the script and then get it through a jquery function but my skills don't seem to be enough.

    May you have any suggestions ? I also mailed avgrund's author but I wanted to see if you could figure a good way to do that.

    Thanks a lot for this plugin and the support forum ( I already found some help reading it :D ).

    Posted 5 years ago on Tuesday March 19, 2013 | Permalink
  2. Quickly reading through the documentation, it appears you can use a function call to set the template parameter? Where did you implement the avgrund.js where the 'template' parameter is set? Maybe it's in your page where you can populate it by shortcode?

    Posted 5 years ago on Tuesday March 19, 2013 | Permalink
  3. 1ternet
    Member

    I have the avgrund call in my footer.php. I tried a do_shortcode in this template parameter, but the best I had gave me a js error, because of some jQuery inside the form itself ( closing script tag ).

    I'm currently trying another way - playing an iframe calling an empty template with the shortcode, inspired by the tip found here: http://mgacreativedesigns.com/gravity-form-in-a-pop-up-box/ - and I'm almost there. It seems to work, now I just need to perfect it !

    After some tests it works perfectly : just some adjustments to with styles !

    Thanks a lot for your attention !!

    Posted 5 years ago on Tuesday March 19, 2013 | Permalink
  4. Sounds like you have it working. Good job and good luck.

    Posted 5 years ago on Thursday March 21, 2013 | Permalink