PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Using GF to add content as a blog post

  1. Okay, I've fooled with this in several different ways and spent time looking through the help forums. But I'm stumped.

    Here is the form I have set up - note that the input fields that I used STILL show in the labels (I did this on purpose so that you guys can see what I did and help me get it fixed)

    I am trying to use GF to have users submit data that will be used as a blog post.
    1. Should the form be set to Pending or Draft?

    I have a category of "wine reviews" then subcategories of "albarino, barbera, cabernet franc, cabernet savignon, etc." Some of these are white, some are red. My intention was to have a multiple choice at the top of the form for 'type of wine?' with red, white, rose, etc. as answers.
    Based on that answer, the next question would be varietal. Using the conditional logic, only the red wine subcategories would show up if the type of wine = red. The user would select the dropdown for that varietal - say Cabernet - which would be the category.

    I tried this using NO CONDITIONAL LOGIC and it always does the same thing - goes directly to Uncategorized. How do I fix this?

    Additionally, the ONLY information that is actually going to the post is the Title and the Post Body. None of the Custom Fields are showing up in the post. I have NOT used the "custom Field Name" entry on the edit form for GF at all - the drop down shows "select an existing custom field" on all of the custom fields. Can somebody explain what I am supposed to be doing with this?

    Sorry if I sound like I'm a newbie, but I am. And if hooks or php are required, well, then I think I may need somebody to outsource this to. . .

    (I loved the GF for the other forms I needed. But I'm hoping I can get this bit figured out)

    Posted 9 years ago on Monday May 17, 2010 | Permalink
  2. We would need access to look at the actual form setting configuration to be able to see what is going on. We would need an admin login to this site to check it out. You can send us this information via our Contact Us form on this site and we can take a look.

    Posted 9 years ago on Monday May 17, 2010 | Permalink
  3. thartzler

    Rats! I have basically the same problem and was hoping to see the answer.
    Mine isn't quite as complicated. I just want the category that is used as the default in the form to actually set the post to that category instead of uncatergorized......

    Have tried to find the answer in this forum but so far no luck.

    Posted 9 years ago on Wednesday June 2, 2010 | Permalink
  4. We did fix a bug in 1.3.12 related to post categories not working correctly.
    We have a version with the fix in it that we haven't made available to the public yet. If you are interested in trying it out, please send me an email to alex[at]

    Posted 9 years ago on Wednesday June 2, 2010 | Permalink
  5. @Jeanette and thartzler: Is it an option for either of you to insert code in the functions.php file in your WordPress theme?

    I have successfully created a form on my site that creates posts in Draft status and sends me an email notification, and I did it using the hooks as explained in the Help page of the Gravity Forms plugin.

    My form is here (currently a dev site). Here's the code I used (link to Pastie):

    Posted 9 years ago on Thursday June 3, 2010 | Permalink
  6. thartzler

    Hey there Alison,
    I like your form.... however I am not sure how your suggestion works for me. It appears that you will moderate the submissions and then post if appropriate. My scenario is just the opposite, I want to default the post to a specific category that is set in the gravity-form and have it published auto-magically. The post gets published however I have to go into wp-admin mode and set the category manually.

    Thanks for your input, if I missed your point please let me know. I am fairly new to all this wp stuff.

    Posted 9 years ago on Tuesday June 15, 2010 | Permalink
  7. @thartzler You shouldn't have to set the category manually. There is a Post Category field that allows them to select the category *OR* you can set a default category on the Post Title or Post Body fields.

    HOWEVER in the current release version of Gravity Forms there is a bug that causes the category to not get set. This is easily fixed by downloading an updated version of Gravity Forms that hasn't been released via automatic upgrade yet.

    If you go to the Downloads page there is a download for the Current Development Release. This fixes the Post Category bug.

    It hasn't been released via automatic upgrade yet as it will be included with v1.3.13 when it is released. We don't like to release single fix updates unless they are critical.

    Posted 9 years ago on Tuesday June 15, 2010 | Permalink
  8. thartzler

    @Alex, @Carl .... Thanks for the bug fix update. It works correctly now and all the submitted forms assign the correct category auto-magically. Huge relief..... the category functionality was the main reason I paid for the plugin.

    Posted 9 years ago on Thursday June 17, 2010 | Permalink
  9. Hey guys

    I dunno if I'm missing something, but I have the same issue and I've just updated to the latest version, and I still don't see the "default category" option?

    Here's what I see:

    Can you assist?

    Thanks much

    Posted 9 years ago on Monday June 28, 2010 | Permalink
  10. @markbloomfield If your form has a Post Category field present, the Default Category field won't appear. The Default Category is only used when no Post Category field exists on the form.

    Posted 9 years ago on Monday June 28, 2010 | Permalink
  11. So there's no way that, for example, a form can ALWAYS post to a default category, in addition to the categories that the user chooses?

    Posted 9 years ago on Tuesday June 29, 2010 | Permalink