PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Validation Field - 1.4.beta 4

  1. begatt
    Member

    I am trying a new form (survey) on 1.4.beta4. It is using conditional logic on almost every field. I am also using the new label/value choices.

    When completing question 11 and question 12 is displayed, I get a validation field that shows up (with question 12) and the following statement:

    "This field is for validation purposes and should be left unchanged."

    The title of this field varies with each loading of the form...sometimes it is "Comment", other times it is "Name".

    <li style="display: list-item;" class="gfield gform_validation_container" id="field_1_27"><label for="input_1_27" class="gfield_label">Name</label><div class="ginput_container"><input type="text" value="" name="input_27"></div><div class="gfield_description">This field is for validation purposes and should be left unchanged.</div></li>

    Why is this field showing up?

    http://cochristianhe.org/dads/confidence-survey/

    Posted 11 years ago on Monday August 16, 2010 | Permalink
  2. I wonder if that's related to the "Spam Honeypot" mentioned here:

    http://www.gravityhelp.com/gravity-forms-v1-4-beta-2-released/

    Posted 11 years ago on Tuesday August 17, 2010 | Permalink
  3. begatt
    Member

    That seems to be it. I didn’t realize I had selected it on the form option.

    It is new and it works, but it is kind of confusing, how it works. There seems to be no way to edit the field and it indicates it is to be left blank.

    Now that I have it off, everything seems to be working.

    Thank you.

    Posted 11 years ago on Tuesday August 17, 2010 | Permalink
  4. I think a hidden field like that is designed to catch spammers. Spam bots and scripts tend to be programmed to fill in all the available fields. If there is a field there with a message that says "don't fill this in if you are human", and a submission comes through with that field filled in, chances are it's spam. It's not intended to be edited by the person creating the form. It just goes into the form as is.

    Glad you got it sorted.

    Posted 11 years ago on Tuesday August 17, 2010 | Permalink
  5. The Spam Honeypot is a hidden field and is a technique to help combat spam bots. It's hidden with CSS. Is it not being hidden when the form is displayed?

    It isn't intended to be edited, and the label is random and uses something common like "Name" or "Comment" to attract spam bots to fill it out. If there is a value in that field then the form submission is considered spam. But average users should not see it as it is hidden with CSS and if by chance they do see it there is a message asking them not to fill it out.

    It is a hidden field that requires a blank value. It was a requested feature by users who prefer spam honeypot's to captcha to help prevent spam.

    Posted 11 years ago on Tuesday August 17, 2010 | Permalink
  6. begatt
    Member

    Thanks Carl. It works, however, it is visible and I was outputting GF CSS...? So, I don't know if the CSS is correct for hiding the field.

    I was able to turn it off and my form works fine.

    Posted 11 years ago on Tuesday August 17, 2010 | Permalink
  7. I don't see it. I went through the entire 20 question quiz (didn't submit) and did not see the spam honeypot field. What browser, browser version and operating system are you using?

    Posted 11 years ago on Wednesday August 18, 2010 | Permalink
  8. begatt
    Member

    Carl - it isn't there anymore. I turned off the spam honeypot and so it works now the way I want it.

    But, I made a copy of the form if you want to see it. The random field appears after question 11.

    http://cochristianhe.org/dads/confidence-survey-copy-1/

    Sorry for the confusion.

    Posted 11 years ago on Thursday August 19, 2010 | Permalink
  9. Found the answer to this and posted it here...

    http://forum.gravityhelp.com/topic/conditional-logic-shows-ramdom-field?replies=3#post-10691

    Seems to happen with conditional fields. Whatever tells the conditional fields to display also adds inline style to the honeypot line and forces that to display. Should be a simple fix though. (see link)

    Posted 11 years ago on Saturday October 2, 2010 | Permalink
  10. @martythornley, thanks for posting this over here as well.

    Posted 11 years ago on Saturday October 2, 2010 | Permalink
  11. Kept seeing the same thing in my forms and it took me a while to figure this out ... nasty side effect of enabling the spam honeypot and should be either documented better or fixed.

    Posted 10 years ago on Monday October 10, 2011 | Permalink

This topic has been resolved and has been closed to new replies.