PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

W3 Total Cache and Fatal error: 30 sec exceeded in functions.php on line 2568

  1. I have a form that I am using on my site... please see it here:

    http://www.jimderosa.com/contact/hire

    It is pretty big on the back end... but has always worked fine.. I installed the w3 total cache plugin and thought it might be the culprit, but if I deactivate it the error still comes up.

    I recently moved my site over to a VPS and enabled the PHP cache by using Xcache... would this have any conflict with gravity forms... I am using dreamhost as my host incase that matters..

    Odd thing is when this error comes up I still get the email from the form? can I increase the timeout past 30 seconds..? any help would be greatly appreciated. Thanks.

    Posted 7 years ago on Friday November 9, 2012 | Permalink
  2. David Peralty
    Administrator

    What do you have in your functions.php file that might be contributing to this error? Usually we would get people to go through the plugin/theme conflict and memory increase instructions, but it seems like something specifically is causing this issue that might be related to custom code in that file (either from the theme developer or from you?) Can you post your functions.php file to pastebin or something similar and link to it so we can take a look. Also, any other information you can give us regarding what is special about your site might help us figure out your issue faster.

    Posted 7 years ago on Friday November 9, 2012 | Permalink
  3. David,

    Thanks for the reply. Let me try to give a run down of what I am working with here. Please bear with me if it too much information.

    Host: Dreamhost VPS
    Options on VPS: PHP cache (Xcache) is active.

    Let's keep in mind I just activated the VPS... before the site was on their shared plan and it worked fine then... I am making an assumption that this is the issue, but it shouldn't be as I am trying to make the site more stable for when I publicize it.

    As I said I get an error upon submitting the form I have created. I made no customizations to any of the core files with the exception of CSS which to me would not attribute to this issue I am having.

    The form located here: http://www.jimderosa.com/contact/hire

    Goes through the page breaks and processes fine... as I said I even get a email when the form is submitted with the results. But the end user is presented with a white page with a generic error...

    I have gotten a few time out errors.. but the one that comes up the most is:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/jderosa3/jimderosa.com/wp-content/plugins/gravityforms/forms_model.php on line 2401

    The pastbin for this file is here: http://pastebin.com/raw.php?i=jEmPGvDZ

    I have also uploaded the XML file of the form itself to pastebin here: http://pastebin.com/raw.php?i=0PNrJVJC

    If you need anything else. Please let me know. Thanks again!

    Posted 7 years ago on Friday November 9, 2012 | Permalink
  4. David Peralty
    Administrator

    Is there any way to reduce the variables in this problem by disabling as many things as possible to make your environment and WordPress install super generic? Something is causing the execution time issue, but being able to figure it out might end up being more of a server log thing than something I can do from my end.

    How did you migrate your site? Can you try the following? http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Can you also see about disabling the caching? All my best!

    Posted 7 years ago on Friday November 9, 2012 | Permalink