PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

W3 Total Cache (enabling minify HTML, CSS, JS ) Breaks My Gravity Form

  1. Activating various W3 Total Cache functions
    made my one Gravity form behave badly.

    i.e. After filling out the form the user clicked the submit
    button but was NOT taken to the confirmation notice so
    naturally they pressed the submit multiple times and I got
    multiple email notifications.

    After testing, I highlighted the problem as being the
    MINIFY HTML, CSS, JS option.

    Enabling this function causes the problem.
    Disabling it eliminates the problem.

    Enabling this function boosts my site speed so ideally
    I would like to be able to enable it so my question is:

    Is there anything I can adjust anywhere to allow the 'minify'
    function to do its job without messing up the function of
    my Gravity form?

    I'd really appreciate any advice.

    Thanks

    Chris :)

    PS. I did post this issue here: http://www.gravityhelp.com/forums/topic/w3-total-cache-and-gravity-forms but thought it best to simply my (over complicated ramblings) with a new thread. Sorry if that is
    considered bad practice.

    Posted 7 years ago on Tuesday September 18, 2012 | Permalink
  2. You did a good job starting a new topic. I was having a hard time figuring out what was resolved and what still needed help.

    The keep Gravity Forms working, you will have to exclude the Gravity Forms scripts from being minified. Minifiying the CSS should be fine.

    Also, you might have a problem receiving entries or notifications when using a caching plugin like W3 Total Cache.

    We're no experts in configuring W3TC for use with Gravity Forms. Our recommendation in the past was to just turn off caching, or if you absolutely needed it, go through the configuration to ensure that form submissions are not cached, and scripts are not minified. Here is one other discussion, although not much useful information there: http://www.gravityhelp.com/forums/topic/w3tcs-html-minify-causing-ajax-issues

    I would check with support for W3 Total Cache and see exactly how to ensure the Gravity Forms form submission and scripts are not modified. I'll leave the topic open in case anyone else has specific experience configuring the caching plugin.

    Posted 7 years ago on Tuesday September 18, 2012 | Permalink
  3. Hi Chris,

    Thanks a lot for your prompt reply.

    I had already seen the thread you mentioned and you're right,
    there wasn't much in the way of useful information.

    I'll take you're advice and head over to the W3TC forum but I'm
    amazed that with the popularity of both Gravity Forms and WCTC
    nobody else had experienced this or knows how to ensure that
    submissions are not cached, and scripts are not minified.

    I'll get back to this thread if I learn anything new but in the meantime
    I'd appreciate any other tips on how to do as Chris Hajer advises.

    Thanks again.

    Chris(CG)

    Posted 7 years ago on Tuesday September 18, 2012 | Permalink
  4. Thank you for keeping us posted.

    Posted 7 years ago on Tuesday September 18, 2012 | Permalink
  5. I've had some kind help over at the W3TC from Bryan Headrick regarding this issue but unfortunately, as I explained to him, his recommendations are way over my head and beyond my capabilities.

    It's a shame it has to be so complicated. :(

    You can read his recommendations at:
    http://wordpress.org/support/topic/plugin-w3-total-cache-minify-conflicts-with-gravity-forms?replies=5#post-3180707

    or below:

    Bryan suggests:
    1. You have to set minify to manual, then just enter the files you do want included in minify on the minify page - or you could just leave that part alone, but still enable the inline minify - it helps somewhat.

    2. What you want to do is view the source from your homepage (ctrl+u on chrome or firefox), and then hit ctrl+f to search for any .css files. Now copy the path of each file in the order they appear in the source into the minify tab.

    You seem to have a lot of js files, so I would do the same thing, but those can be a little more tricky to get right if you don't know what every script does. You might want to try just installing a js to footer plugin to see how well that helps.

    If you do the js minify, add them one at a time and then check to see if it broke anything before moving to the next.

    If you just chose combine only, it would help quite a bit.

    Here's what I have on my settings:

    general/html/xml

    For the theme, select your active theme, which would be the child theme(if you're using a child theme). (not sure why sometimes (active) is next to a theme that isn't active).

    then, just click the "add a stylesheet/script" button and add the path for each file. make sure you have these in the order that they are on your site. You can drag the files around to reorder them.

    Posted 7 years ago on Wednesday September 19, 2012 | Permalink