PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

W3TC's "HTML minify" causing AJAX issues

  1. I'm having trouble with the AJAX options on Gravity Forms. When I have AJAX enabled for submissions (nothing fancy on the form), the form submits, browser tab loads, but the AJAX icon keeps spinning and the thank-you message never shows.

    I traced this to W3 Total Cache's Minify settings. Oddly, I can leave Javascript and CSS as minifying, but simply disabling only "HTML & XML" minification makes the AJAX work.

    I can disable or enable:
    Inline CSS minification
    Inline JS minification
    Don't minify feeds
    Line break removal
    … but none of these affect it. Only the option just above these, "Enable" for the HTML minify settings, will break the AJAX.

    Ignored comment stems is set to:
    google_ad_
    RSPEAK_

    I've even compared the rendered source between HTML-minified and non-minifed between cache refreshes and there's no difference beside only the basic minifications like:

    </script>
    <div …

    to:

    </script><div …

    I've read through the other posts here and can't find anything that will help. I have database cache configured correctly. It's only this HTML minification that breaks the AJAX.

    Thank you in advance for your help.

    Posted 8 years ago on Thursday March 1, 2012 | Permalink
  2. Hi, DJosephDesign,

    I installed the plugin you are referencing and set the items up the way you mention, but mine isn't breaking. Can you tell me what all the settings are on your Minify page for each section and the General page (some minify settings are there too) so I can get mine set the exact same way as yours? I have never used this plugin before so please include any other settings that may be useful. Can you also tell me what version of Gravity Forms and browser you are using?

    There have been some recent releases of Gravity Forms, so it is best to install the latest in case we have fixed something along the way.

    Thanks.

    Posted 8 years ago on Thursday March 8, 2012 | Permalink
  3. I shared my exact settings above. No minification except for HTML as described above, minification settings on their defaults in the W3TC general settings.

    Posted 8 years ago on Saturday March 17, 2012 | Permalink
  4. I am not really sure what is causing the issue. The best thing to do is leave that setting off, like you are doing, or disable AJAX on the form.

    We do plan in the future to work on making Gravity Forms more compatible with minification scripts.

    I know that doesn't help you now, but hopefully you can work with one of the two possible workarounds.

    Posted 8 years ago on Monday March 19, 2012 | Permalink

This topic has been resolved and has been closed to new replies.