PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Won't go to pay

  1. Not sure what is happening here.. i'm working on a new website that accepts a small payment each year. The same form is creating a user and subscribing the user to mailchimp.

    form: http://photowriter.net/join/

    no matter what I do I can't get it to submit the payment to paypal.

    Posted 9 years ago on Wednesday December 28, 2011 | Permalink
  2. Whenever a form won't redirect the user to PayPal as expected it is going to be due to either how the Pricing Fields were used or how the PayPal Feed was setup for the form.

    It's difficult to tell just from looking at the front end form itself, i'd need to see the form and PayPal settings.

    Email me at carl@rocketgenius.com and provide me with a WordPress admin login for the site and i'd be glad to take a look and see what the issue is.

    Be sure to reference this forum post when contacting me so I know what it is in reference to.

    Posted 9 years ago on Wednesday December 28, 2011 | Permalink
  3. thanks Carl,

    i'll send that now

    Posted 9 years ago on Wednesday December 28, 2011 | Permalink
  4. The issue is you only have one Product Field on that form, configured as a Single Product field type and you disable it's quantity field option. See this screenshot:

    http://dl.dropbox.com/u/185347/Slingshot/Pictures/Screen%20Shot%202011-12-27%20at%208.35.23%20PM.png

    But when you did that, you didn't also then add a standalone Quantity field to the form so that a Quantity for this Product could be selected. The ability to disable the Quantity is there so you can use the standalone Quantity field as an alternative. If no Quantity field exists for that Single Product Field then there is no Quantity... if there is no Quantity then there is no Total and no order... which is why it isn't redirecting to PayPal.

    What I did was I added a Quantity Field from the Pricing Fields to your form. I positioned it underneath your Product Field. I then set it's field type to Hidden and it's Default Value to 1.

    One thing to note is this Quantity field is automatically associated with the only Product Field on your form. If multiple Product Fields existing on your form, there would be a drop down to select which Product Field it is associated with. We'll be changing that to make that field selection drop down always visible to avoid some confusion that causes some users.

    After adding the hidden quantity field with the default value of 1 to your form, it now submits to PayPal as intended because there is no a quantity associated with that Product.

    Posted 9 years ago on Wednesday December 28, 2011 | Permalink
  5. Got it! Thank you Carl !!

    Posted 9 years ago on Wednesday December 28, 2011 | Permalink

This topic has been resolved and has been closed to new replies.