PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

WordPress Crashes when Gravity Forms Plugin is Activated

  1. When I click "Activate Plugin" after gravity forms is uploaded WordPress Crashes and all Admin pages are blank.

    When I login via ftp and delete the plugin, WordPress begins to work properly again.

    I have deleted and reinstalled and attempted to reactivate gravity forms several times.

    What's wrong?

    I'm running wordpress 3.3.1 .

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  2. I confirmed that I'm running PHP Version 5.2.6.

    As well, I installed the WordPress Theme "Twenty Ten" and then tried to activate the plugin. Again, WordPress Admin freezes and shows nothing but blank pages.

    The only solution I've found to restore WordPress admin is to change the name of the gravityforms folder in the wordpress plugins folder to something other than the original name.

    Is gravity forms 1.6.3.1.2 compatible with wordpress 3.3.1?

    Help please!!!

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  3. Check your server logs. A blank screen is normally a 500 Internal Server error. It could also be a problem where PHP is running out of memory. However, they're all guesses until you can see the error log. With the actual error, we should be able to help you get it activated.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  4. Thanks for the reply Rob. Can you help me know how to check the error logs? That's new for me...

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  5. Here is the log error message:

    [Mon Mar 05 09:47:14 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258, referer: http://transformingafrica.org/wp-admin/plugins.php

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  6. I also saw this error right above it but at a different time:

    [Mon Mar 05 02:43:40 2012] [error] [client 196.44.240.59] PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 77824 bytes) in /var/www/vhosts/transformingafrica.org/httpdocs/wp-admin/includes/schema.php on line 912, referer: http://transformingafrica.org/wp-admin/plugins.php

    According to my Plesk Server System Usage settings I have over 500mb of memory left. So, I don't understand this error...

    Help!

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  7. I also just bought the product - installed it - activated and boom - same issue - cannot get to wp-admin now...as you can imagine...not happy!

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/squarem1/public_html/wp-admin/includes/schema.php on line 523

    How do I dig myself out of this mess and can I have my money back please!

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  8. GMWilliams,

    To get yourself out of this mess, login to your ftp, delete the gravityforms folder or change the name.

    then reload your wp-admin dashboard and everything will work fine.

    I don't know how to get around the error and make gravity forms work, but I do know that there is something about installing gravityforms that causes this error, so removing takes away the error.

    Good luck on getting your money back!

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  9. Thanks macnrwanda08 - I ftp'd to the site as you suggested, renamed the plugin and I can get back in - but what a mess - I literally bought this 10 minutes ago for $99 and all I have to show for it is a headache. Hopefully the gravity guys will have a solution or I will definitely get my money back.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  10. This is not a Gravity Forms issue, bug or code problem.

    This is a web server resource issue. The error you are getting is a PHP memory issue. You are running out of available PHP memory which is why you are encountering these issues.

    In @GMWilliams case it's not even coming from Gravity Forms based on the error he provided:

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home/squarem1/public_html/wp-admin/includes/schema.php on line 523

    The error is coming from a core WordPress file.

    But again, this is due to the fact you don't have enough PHP memory available for your site.

    The solution to this issue is to increase your available PHP memory. This is a web server setting that controls how much memory is allocated to PHP on your web site. A lot of shared web hosts default to a very low amount of PHP memory and it's necessary to increase this amount by updating the PHP settings.

    Here is a tutorial on how to do so:

    http://www.nerdgrind.com/increase-wordpress-and-php-memory-limit/

    You may need to contact your web host and discuss this with them if you are unable to follow the instructions in that tutorial or are unsure how to do so.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  11. My Gravityforms was working fine, and now after the upgrade - white pages for the wp-admin panels.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  12. HI, thanks - it was easy to do. Unfortunately it still resulted in the same error message.

    I de-activated several other plug-ins for good measure but to no avail.

    I will try several other options.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  13. I de-activated several plugins and now it works. You are right - it is a PHP memory error. So the options are - deactivate the plugins you do not use - or increase the memory as shown above. Thanks for your help.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  14. Thank you for the post and explanation.

    This is extremely complicated, especially having to edit the php.ini file! I have never had a plugin require so much memory as to require this...

    Can you help me edit the php.ini file?

    Thanks so much!

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  15. Like I said, this isn't a Gravity Forms specific issue. It's related to how many plugins you have activated and what plugins they are. The more plugins you use, the more memory you use. The more complex your theme is, the more memory you use.

    It's an aggregate things, it's not just Gravity Forms itself and not something Gravity Forms itself is causing, it's simply related to your web hosts server settings not enabling enough resources.

    Most users don't encounter this issue. It's entirely dependent upon your hosting settings and not something we have any control over.

    Posted 10 years ago on Monday March 5, 2012 | Permalink
  16. Thank you again for your post... I have a dozen different wordpress blogs with dozens of plugins and websites and have never encountered this problem until i tried to activate the gravity forms plugin. While I understand that it is a server issue, there is something about your plugin that uses up more resources than others.

    I understand what the problem is but still do not know how to fix it.

    Posted 10 years ago on Tuesday March 6, 2012 | Permalink
  17. I deactivated all but four plugins relating to my woocommerce site and still have this same problem.

    Can we still say it's because i have too many plugins installed?

    Still looking for a solution...

    Posted 10 years ago on Tuesday March 6, 2012 | Permalink
  18. Here is the error that I am receiving:

    [Mon Mar 05 03:08:39 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258, referer: http://transformingafrica.org/wp-admin/themes.php?activated=true
    [Mon Mar 05 09:47:14 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258, referer: http://transformingafrica.org/wp-admin/plugins.php
    [Mon Mar 05 10:04:33 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258
    [Mon Mar 05 10:04:46 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258
    [Mon Mar 05 10:11:05 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258
    [Mon Mar 05 10:58:23 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258
    [Mon Mar 05 11:06:29 2012] [error] [client 196.44.240.59] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258
    [Tue Mar 06 00:25:45 2012] [error] [client 196.44.240.57] PHP Fatal error: Class 'RGFormsModel' not found in /var/www/vhosts/transformingafrica.org/httpdocs/wp-content/plugins/gravityforms/gravityforms.php on line 258, referer: http://transformingafrica.org/wp-admin/plugins.php

    As you can see, it's not a memory error.

    Posted 10 years ago on Tuesday March 6, 2012 | Permalink
  19. I was hasty - I get a spinning sign - cannot save the form, Then contacted the hoster UK2.NET with a recommendation from Gravity about altering the mod_security settings to prevent the spinning disc and got this:

    Unfortunately, to prevent exploits from running on our server, and to help secure accounts, we cannot adjust the mod_security settings currently in place on the server. Adjusting the settings on this security feature, especially for a content management system like Wordpress, which is already prone to security exploits, is not possible on our servers.

    Posted 10 years ago on Tuesday March 6, 2012 | Permalink
  20. SOLUTION FOUND!!!

    Deactivate all plugins on site.

    Install and activate gravity forms.

    Reactivate plugins... Worked great!

    In my case I was running woocommerce and by deactivating that i was able to activate gravityforms and then reactivate woocommerce and other plugins...

    Hope this helps others!

    Posted 10 years ago on Tuesday March 6, 2012 | Permalink
  21. Glad you resolved it. The fact that it was resolved by deactivating and reactivating plugin sounds like something wasn't configured right with your WordPress site with how it handles plugins. Sometimes deactivating and reactivating ALL plugins does resolve issues in these situations.

    Posted 10 years ago on Tuesday March 6, 2012 | Permalink

This topic has been resolved and has been closed to new replies.