PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

WP eMember and Gravity Forms - Conditional Logic Conflict

  1. I am currently using WP eMember V7.9.8 and Gravity Forms V1.7.2.

    I am able to create forms without a hitch. However as soon as I add conditional logic the form disappears. If I disable WP eMember, the form appears and the conditional logic functions correctly.

    Is this a known issue and if so, is there a solution? Many thanks,

    Bella :)

    URL for test site here - thanks
    http://www.firefightersday.org/megandredge/schools/beginning-teachers-starter-pack-for-schools/

    Posted 5 years ago on Sunday May 12, 2013 | Permalink
  2. Richard Vav
    Administrator

    Bella,

    Can you reactivate WP eMember so I can examine the page when the form does not appear. When a form that uses conditional logic fails to appear it is because a javascript error is preventing the gravity scripts from revealing the form, the most common cause is multiple and/or incorrect versions of jQuery being included on the page but without the plugin active I can't tell.

    Regards,
    Richard

    Posted 5 years ago on Sunday May 12, 2013 | Permalink
  3. Thanks Richard.. activated... the whole form has disappeared now.

    Posted 5 years ago on Sunday May 12, 2013 | Permalink
  4. Richard Vav
    Administrator

    There is a javascript error on line 94

    Uncaught TypeError: Object #<Object> has no method 'overlay'

    this error is in a function added to your page by the eMember Plugin, a bit of research reveals that versions prior to 8.4.1 experienced javascript errors when wordpress 3.5 was released.

    Please upgrade to eMember v8.4.1 or greater and then check to see if your problem remains, it is allways advisable to ensure you keep plugins and wordpress updated.

    Posted 5 years ago on Sunday May 12, 2013 | Permalink
  5. Hi Richard

    Thanks for your prompt response! I have upgraded to eMember Version v8.6.4 and the problem remains. I have left the plugin activated if you have a chance to troubleshoot again :)

    Bella :)

    Posted 5 years ago on Sunday May 12, 2013 | Permalink
  6. Hi Richard, problem is solved. For anyone else experiencing this issue here is the solution as provided by the team at WP eMember. Regards, Bella :)

    _______________________________

    Hi Bella, Please do the following and let me know how it goes after that:

    1) Find the following settings field:

    WP eMember Settings -> Pages/Forms Settings -> Password Reset Page

    2) Read the help text for that field and do what it says.

    3) Refresh your webpage and tell me if you still see the error.

    _______________________________

    I basically created a Password Reset page and it worked, how odd! :)

    Posted 5 years ago on Monday May 13, 2013 | Permalink

This topic has been resolved and has been closed to new replies.