PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

XML E-mail to ADF Suddenly Stopped Working

  1. I created a program with Gravityforms which takes user input, combined with hidden field values, to send form data via text-format email, with valid XML markup. It was working fine for about six months, then suddenly stopped working. I can only attribute this to a recent upgrade, as no other modifications were made to the code which controls the XML e-mail.

    Was there a change in the framework that might have caused this to happen? Whereas before, the emails were being parsed automatically and inserted into the customer's CRM, now they are just coming through unparsed. No changes have been made to the CRM, and apparently all other email-to-ADF XML that is coming into their CRM is still working just fine.

    Have spent hours researching this, messing with the code, and trying to find the answer. Desperate for a solution here. Please advise.

    Posted 7 years ago on Wednesday December 5, 2012 | Permalink
  2. Oh, and in case nobody knows what ADF is...

    Here is the Wikipedia entry on it, and here is the PDF documentation.

    ADF is basically the universal format for customer/lead data for auto dealerships around the world. It is how they communicate between all the various departments, including service, sales, distribution, etc.

    If it helps, here is the XML output that I am sending (in text-only email format). I will paste example email headers below the code:

    <?XML VERSION=“1.0”?>
    <?ADF VERSION="1.0"?>
    <adf>
        <prospect>
            <requestdate>2012-11-30</requestdate>
            <vehicle>
                <year>2013</year>
                <make>Audi</make>
                <model>A4 2.0T</model>
            </vehicle>
            <customer>
                <contact>
                    <name part="full">TESTING ADF LEAD FORM – XML STRUCTURE REVISED</name>
                    <phone>(123)456-7890</phone>
                    <email>someonewho@isntme.com</email>
                </contact>
                    <comments>Not Specified</comments>
            </customer>
            <vendor>
                <contact>
                    <name part="full">VENDOR NAME</name>
                    <phone>123-456-7890</email>
                    <email>test@autowebsite.com</phone>
                </contact>
            </vendor>
            <provider>
                <name part="full">PROVIDER NAME</name>
                <service>SERVICE</service>
                <url>http://somewhere.com/</url>
                <email>test@somewhere.com</email>
                <phone>123-456-7890</phone>
            </provider>
        </prospect>
    </adf>

    Email headers (note the OMITTED elements were omitted by me, of course):

    X-Priority: 3
    X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
    MIME-Version: 1.0
    Content-Type: text/plain; charset="UTF-8"
    X-SMTPCOM-Tracking-Number: OMITTED
    X-SMTPCOM-Sender-ID: OMITTED
    X-SMTPCOM-Spam-Policy: SMTP.com is a paid relay service. We do not tolerate UCE of any kind. Please report it ASAP to abuse@smtp.com
    Content-Transfer-Encoding: quoted-printable
    Return-Path: OMITTED
    X-MS-Exchange-Organization-SCL: 1
    X-MS-Exchange-Organization-AVStamp-Mailbox: OMITTED
    X-MS-Exchange-Organization-AuthSource:
     OMITTED
    X-MS-Exchange-Organization-AuthAs: OMITTED
    Posted 7 years ago on Wednesday December 5, 2012 | Permalink
  3. Are the emails making it the the customer's CRM?

    Can you compare an email you created 6 months ago to a current email which is not being parsed?

    Posted 7 years ago on Thursday December 6, 2012 | Permalink
  4. I'm thinking that the issue may have to do with the content-type and charset I was using to send. Perhaps an auto-upgrade to the CRM is now disallowing the content-type text/plain (which I now realize is PROBABLY wrong). In your experience, when sending XML content via email to be parsed, what is the correct content-type and charset?

    My research has come up with:

    Content-Type: Application/xml-external-parsed-entity
    Charset: UTF-8

    Would this be correct?

    Posted 7 years ago on Thursday December 6, 2012 | Permalink
  5. I'm not sure what is technically correct, but whatever header their CRM needs to see is the one I would send.

    Posted 7 years ago on Friday December 7, 2012 | Permalink
  6. Still nothing, unfortunately. Can you determine any other reason why a recent update would have affected the format or headers of the system which was previously working with text/plain as content-type? Tried the above, as well as text/xml content types and nothing has worked.

    Posted 7 years ago on Friday December 7, 2012 | Permalink
  7. It sounds like that's a question for the CRM provider. The content type you were sending was unchanged, but they stopped accepting the data in that format.

    Posted 7 years ago on Tuesday December 11, 2012 | Permalink