PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

You do not have sufficient permissions to access this page.

  1. Hi, same issue here than others :
    Once I have uploaded and activated the Gravity Forms I get the following error message whenever I try to add a form, edit settings or anything else "You do not have sufficient permissions to access this page."

    I don't have any role manager activated, and check on phpmyadmin to see the level of amdin or my user and it appears correct (to 10) I also see gravity full access on php my admin.

    For your information, this trouble appears with no other plugin than gravity AND tdo miniform (i also tried this one).

    Any hook to fix this quickly please ?

    Posted 9 years ago on Tuesday November 2, 2010 | Permalink
  2. This is a conflict. If you deactivated ALL other plugins then it is possible that is your theme that is causing this issue. We have seen this when themes add theme option pages incorrectly to WordPress.

    To test for a theme conflict you need to activate the default WordPress theme (TwentyTen on WordPress 3.0+) and see if the issue still occurs. If it works fine on TwentyTen then something in your theme is causing the problem, most likely the theme is doing what I described above. Adding a theme option page but not doing so properly which can interfere with option pages added by plugins.

    Posted 9 years ago on Tuesday November 2, 2010 | Permalink
  3. ok, i solved the problem: This message appears when themes use an admin.php page instead of a x-admin.php page. Thanks Carl.

    Posted 9 years ago on Tuesday November 2, 2010 | Permalink
  4. ernest
    Member

    Hello Carl,

    You do not have sufficient permissions to access this page.

    This is the message I get each time I try to Create a new page. What do I do?

    I have tried the following without success.
    1. Deactivated all other plugins, before trying again......same response.
    2. I changed the plugin (activated the twenty ten default theme) and get the same response. SEEMS NOT TO BE A THEME CONFLICT.

    I don't know how to go about Wecho's solution. Any other?

    Posted 9 years ago on Tuesday November 9, 2010 | Permalink
  5. ernest,
    Could you send me an WP admin login to alex@rocketgenius.com? I will need to take a closer look.

    Posted 9 years ago on Wednesday November 10, 2010 | Permalink
  6. ernest
    Member

    Thank you Alex, I have just done so. Looking forward to hearing from you with hopes of an Express solution.

    Posted 9 years ago on Thursday November 11, 2010 | Permalink
  7. ernest
    Member

    Hellooooo Alex, am waiting!

    Posted 9 years ago on Thursday November 11, 2010 | Permalink
  8. @ernest Alex has had several other sites to look at as well today and has other folks in the queue too, trust me, he'll get back around to you as soon as he can.

    Posted 9 years ago on Friday November 12, 2010 | Permalink
  9. ernest
    Member

    Alex, you are simply awesome. Yes I deleted all the installation files from my ftp server and re-installed with the updated version you sent to me and once I activated the plugin, I rushed to create anew form and VOILAAAA, all the particulars came up. Thank you Alex, am sorted.

    @ernest Alex has had several other sites to look at as well today and has other folks in the queue too, trust me, he'll get back around to you as soon as he can.

    @Kevin, ....... you were correct, Alex came back to me in good time.

    Posted 9 years ago on Friday November 19, 2010 | Permalink
  10. @ernst That's great news and yes, Alex is way awesome.

    Posted 9 years ago on Friday November 19, 2010 | Permalink
  11. Hi
    I seem to have the same problem as the other guys in this thread. I cant submit forms as i keep getting "Forbidden - You don't have permission to access "some-url" on this server." I don't know what the x-admin.php hack is and Ive tried deleting the plugin and reinstalling with not luck. Ive also tried to change the theme to Twenty Ten.
    Any help appreciated

    Cheers
    Bonsak

    Posted 8 years ago on Tuesday January 17, 2012 | Permalink

This topic has been resolved and has been closed to new replies.