PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Conflict with qTranslate

  1. Hi,
    I found something you might want to take a look at. For some reason Gravity forms seems to have a conflict with how qTranslate ( handles permalinks. With Gravity forms activated links in my menu suddenly start redirecting to the wrong page, and this is with not having any Gravity Forms powered forms on the site. Once deactivated the problem is fixed and the site resumes normal functionality. I'm not a programmer so I really have no idea why this might work this way, any idea why this might be?

    The qTranslate forum has a quick guide for plug-in devs on how to make their plugins work with qTranslate ( .) I know it might not be in your best interest to try to fix problems with every conflicting plugin, but with 73,000+ downloads and reccomend by Matt ( maybe a quick look might help.

    In case you were wondering, I disabled every plug-in on the site I was working on and re-enabled them one by one until I found that Gravity Forms was the cause of the problem (I initially suspected WP Super Cache). Wordpress is latest version WordPress 2.8.4 as well as latest version of Gravity Press.

    In case you want to know more specifics about the site and forms, please email me at nicmyers (at) as I don't want to publish the links on a public forum.

    Thanks in advance.

    -Nic Myers

    Posted 13 years ago on Sunday September 27, 2009 | Permalink
  2. I'll be in touch Nic, i'll install qTranslate locally with Gravity Forms and recreate the issue on our end so we can see what is going on.

    Gravity Forms does nothing with permalinks which makes this issue very odd. It could very well be an issue with how qTranslate is doing something and not Gravity Forms but we won't know until we do some testing.

    Posted 13 years ago on Sunday September 27, 2009 | Permalink

This topic has been resolved and has been closed to new replies.