PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Email notification to user does not contain any line breaks

  1. I have a form that sends a confirmation email to the email address entered in the email thanking them for their submission. The text I enter for this notification contains line breaks. The email that the user gets does not. Am I doing something wrong? Please help, thanks!
    Yaron

    Posted 9 years ago on Thursday March 22, 2012 | Permalink
  2. interpos
    Member

    HI GF support
    I am having the same problem - it seems that the visual editor is not populating line breaks in the html equivalent when I setup the form notification. I have tinymce plugin installed.
    Hope you can help.
    Many thanks
    John

    Posted 9 years ago on Friday March 23, 2012 | Permalink
  3. @trestian - are you sure that you don't have the "disable auto formatting" option selected?
    screenshot: http://bit.ly/GMu5Kd

    @interpos - same thing.. are you sure you haven't disabled the auto formatting and also, WordPress comes bundled with TinyMCE so you shouldn't need an additional plugin or anything to enable that in the backend.

    Posted 9 years ago on Friday March 23, 2012 | Permalink
  4. Weird. I don't have that "disable auto formatting" checkbox on my screen. Going into Firebug I see it but it's display is set to none.

    screenshot: http://dl.dropbox.com/u/2869272/no-auto-format.png

    ideas?

    Posted 9 years ago on Friday March 23, 2012 | Permalink
  5. elvis.da.pelvis
    Member

    The same here. The checkbox doesn't appear anymore.

    Posted 9 years ago on Sunday March 25, 2012 | Permalink
  6. damiendasher
    Member

    I am also having the same problem and I do not see any option to disable auto-formatting. I hope you can help as the emails just look terrible streamed together like that.

    Thank you

    Posted 9 years ago on Monday March 26, 2012 | Permalink
  7. I am having the same issue, I have made no changes to the form since updating to the most recent Gravity Forms version. It was fine before the update.

    Posted 9 years ago on Monday March 26, 2012 | Permalink
  8. Same problem here.

    Posted 9 years ago on Monday March 26, 2012 | Permalink
  9. The visual editor is displaying the message correctly with line breaks. The actual email doesn't.

    You can visit my live form and submit a test to see what the email reply comes through as if you need to: http://www.giveawaypromote.com/submit-giveaway/

    Posted 9 years ago on Monday March 26, 2012 | Permalink
  10. damiendasher
    Member

    @Rob Harrell, thanks for the link to that thread but that is not the problem. The problem is that the email notifications that the end user receives after filling out the form are unformatted even if you format them in the html/visual editor. The email received is just a one big long sentence without any breaks almost looking like there were no returns when the email was created. This has occurred since the most recent update of gravity forms. What can be done to correct the problem? I've had to turn off all email notifications on client's sites so that my clients don't look unprofessional when people fill out their forms. Any help to resolve this is much appreciated.

    Posted 9 years ago on Monday March 26, 2012 | Permalink
  11. We are aware of the issue and have already patched it internally. An update will be released later today that addresses this issue. Keep an eye out for automatic updates to appear and install the update when you see it is available. Check for updates by going to the Updates menu item under Forms.

    Posted 9 years ago on Monday March 26, 2012 | Permalink

This topic has been resolved and has been closed to new replies.