PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Export entries with special characters

  1. I can export form entries with special character (Danish characters æ, ø, å) but they don't show correctly when exported. The characters are replaced by other characters meaning that I have to manually go through all entries and correct the errors.

    Anything I can do to make sure the special characters are kept?

    Posted 10 years ago on Wednesday August 17, 2011 | Permalink
  2. Anonymous
    Unregistered

    I have possibly a similar issue. When I export the first cell always has odd characters in it, and puts in quotes, regardless of which form I export. Example:

    Ôªø"Whatever Question Title Is"

    Posted 10 years ago on Wednesday August 17, 2011 | Permalink
  3. Same here: "Question title"

    Posted 10 years ago on Wednesday August 17, 2011 | Permalink
  4. @alsc Do me a favor and send me a WordPress admin login for this site to carl@rocketgenius.com so we can take a look at the form, and export the data and see the issue happening so we can debug it.

    Posted 10 years ago on Wednesday August 17, 2011 | Permalink
  5. @carl: Done.

    When you are logged in, you may also have a look at the form list (see: http://www.swingshoes.dk/filer/gravity-forms.jpg ) with Wordpress links in the middle of the form list.

    Posted 10 years ago on Thursday August 18, 2011 | Permalink
  6. alsc, the footer floating up problem has been addressed in version 1.6.

    Posted 10 years ago on Thursday August 18, 2011 | Permalink
  7. @Chris: Thank you.

    @Carl: Any news with the export issue?

    Posted 10 years ago on Wednesday August 24, 2011 | Permalink
  8. @Carl: Did you try my login info?

    Posted 10 years ago on Monday September 5, 2011 | Permalink
  9. The issues goes beyond the "Question title". It actually affects all exported fields which is a huge nuisance. For an example: http://www.swingshoes.dk/filer/gravity-forms-004.jpg

    Posted 10 years ago on Friday January 27, 2012 | Permalink
  10. Hi,

    It turns out that I have the same problem with French accents. The accents are displayed correctly when viewed in a Web browser, but not when exported: the accents are systematically replaced by junk characters.

    Posted 10 years ago on Tuesday January 31, 2012 | Permalink
  11. fabianlarab
    Member

    Hi
    I have the same problem, we're collecting web leads and the passing data field to a netsuite form (crm) via the Pass Field Data Via Query String. The problem we're having is when exporting entries, latin characters are not passed correctly (á ó é í ú ñ etc), and takes time to edit these.

    Is there a solution for this? Thanks

    Posted 10 years ago on Tuesday March 20, 2012 | Permalink
  12. Same for spanish special characters, it makes it unusable for thousands of records....

    Posted 10 years ago on Friday June 1, 2012 | Permalink
  13. David Peralty

    I will let our developers know about the latest stuff on this thread and see what we can come up with.

    Posted 10 years ago on Friday June 1, 2012 | Permalink
  14. I am having a little trouble replicating the issue. My export file looks right even when I have the special characters mentioned above. If you can send me a WP admin login as well as an FTP login to alex@rocketgenius.com, I will be glad to take a closer look at your server and try to figure out what is causing the problem.

    Posted 10 years ago on Friday June 1, 2012 | Permalink
  15. Same problem here. Is everyone else using a Mac ?

    Posted 10 years ago on Thursday June 7, 2012 | Permalink
  16. Ôªø"Title"

    Major issue as my client exports the csv for import into third party software.

    The Ôªø""

    Makes this manual and unusable

    This thread has been running a very long time can we get something happening?

    Posted 10 years ago on Tuesday July 17, 2012 | Permalink
  17. I've found that forcing UTF-8 encoding on the import takes care of this. I used to have this trouble all the time with Open Office but on importing the CSV, if I changed from the default encoding ( ISO 8859-1 I believe) to UTF-8, it worked fine.

    Recent discussion:
    http://www.gravityhelp.com/forums/topic/export-special-character#post-64000

    Posted 10 years ago on Tuesday July 17, 2012 | Permalink
  18. nicomollet
    Member

    Importing a CSV on MacOS Excel still doesn't encode special chars correctly.
    Is there any way to change the encoding on (MacOS) Excel ?

    Posted 9 years ago on Tuesday September 18, 2012 | Permalink
  19. nicomollet
    Member

    I found the answer to my question.

    In Excel MacOS, there is an option in the import CSV panel, that lets you change the encoding.
    It's called "File origin", as shown in this capture:
    http://x3ro.de/wp-content/uploads/2012/04/ExcelUnicode.png

    Change encoding to UTF-8.

    Posted 9 years ago on Tuesday September 18, 2012 | Permalink
  20. David Peralty

    Hi Nocomollet - there are tons of articles about this. Here is one that might interest you and help explain the issue:

    http://stackoverflow.com/questions/6588068/which-encoding-opens-csv-files-correctly-with-excel-on-both-mac-and-windows

    Posted 9 years ago on Tuesday September 18, 2012 | Permalink
  21. nicomollet
    Member

    Sorry David, I don't have a Mac and was pretty blind to try to fix this.
    My client is on Mac and had to explain it how to do it.
    Hopefully I found a easy solution http://www.gravityhelp.com/forums/topic/export-entries-with-special-characters?replies=18#post-76067 , which do not require any programming.

    Posted 9 years ago on Tuesday September 18, 2012 | Permalink
  22. David Peralty

    You should be good to go. :)

    Posted 9 years ago on Tuesday September 18, 2012 | Permalink

This topic has been resolved and has been closed to new replies.