PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Fatal error upon trying to activate

  1. I receive the following error message when trying to activate Gravity Forms upon installation:

    "Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in .../gravityforms/gravityforms.php on line 95"

    Can someone please advise me on how to activate this? Thanks!

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  2. I should add that I'm running PHP 5.3.16. I had read the FAQ section and it discussed problems while running PHP 4 but I'm not.

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  3. David Peralty
    Administrator

    Are you using the latest WordPress and Gravity Forms releases? Is this a new site? Can you try the following after re-installing Gravity Forms through FTP?

    http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Let me know the results please.

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  4. Hi David,

    No, I'm not using the latest version of WordPress. I'm using Wordpress 3.1.1 and that's because I cannot afford any downtime if the upgrade goes awry. Is the latest version of Wordpress necessary to have in order for the plugin to work?

    I just purchased Gravity Forms today--version 1.6.7. I haven't checked to see what the latest version is. Since I just purchased it, I was under the understanding that I purchased the latest version.

    I am willing to try to install it through the FTP process provided there are no issues with the plugin working with WP 3.1.1. I'll await to hear from you.

    Thanks so much for your help! I so very much appreciate it :)

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  5. David Peralty
    Administrator

    As per the requirements listed at the bottom of every page, Gravity Forms requires WordPress 3.3+.

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  6. I'm sorry. I didn't catch that earlier. I will attempt to update my site now and hope for the best :/ Thanks again for your help!

    Posted 7 years ago on Thursday September 20, 2012 | Permalink
  7. It worked, David! Thank you for your help :)

    Posted 7 years ago on Friday September 21, 2012 | Permalink
  8. Thank you for the update. Glad it's working for you now.

    Posted 7 years ago on Saturday September 22, 2012 | Permalink

This topic has been resolved and has been closed to new replies.