PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

multi page stops loading the next page

  1. Hi,

    I am ver new to this so please be patient.

    I have a very complex form which is very slow between page loading and often does'nt load the next page.

    What could be the problem?

    Any help would be greatly appreciated

    Posted 7 years ago on Monday March 4, 2013 | Permalink
  2. Richard Vav
    Administrator

    Unfortunately without seeing the form it is impossible to say. Can you post a link to a page containing the form in question.

    Posted 7 years ago on Monday March 4, 2013 | Permalink
  3. Thanks,

    Sorry, as I mentioned I'm new to this

    here is the link on a test page
    http://www.theheffect.com/the-h-effect/congratulations/test-new-contact-from/

    Thank you for your time

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  4. Hello,

    I'm also experiencing something similar with the form here: http://www.ridgelandharvest.com/csa/csa-sign-up

    It typically takes about 10-15 seconds between page steps and takes long to submit the form as well. I experience the same slowness on localhost and have tried deactivating all other plugins without much change.

    Is this just an aspect of multi-page forms?

    Thanks,
    - Jonah

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  5. David Peralty
    Administrator

    Can you both try ajax=true in your form embed and see if that improves the pagination speed?

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  6. Hi David,

    Mine is already set that way.

    - Jonah

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  7. David Peralty
    Administrator

    Can I have you both try the following. There might be another plugin causing the issue. http://www.gravityhelp.com/documentation/page/Testing_for_a_Theme/Plugin_Conflict

    Also, if you are running any caching plugins, it might be part of the reason for the issue.

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  8. Hi,

    Thanks I had originally turned ajax on. Turning it off possibly helped the speed.

    I have also tried using different theme and plugins turned off. didn't make any differance.

    Thanks in advance

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  9. David Peralty
    Administrator

    Can you tell me more about your server environment? Did you see no speed increase when all the other plugins were turned off, and the theme was the default WordPress theme?

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  10. The only plugin used is gravity forms. Nothing changed in word press default theme

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  11. Just trying twenty twelve theme, seems faster.

    Not sure of page sticking yet, but it doesn't always happen

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  12. ok twenty twelve theme is deffinately faster and no sign of sticking!

    Does this mean I need to change my theme?

    Posted 7 years ago on Tuesday March 5, 2013 | Permalink
  13. It means your theme has room for improvement. You don't necessarily have to change the theme, but you should contact the theme provider to let them know about this issue.

    Posted 7 years ago on Thursday March 7, 2013 | Permalink
  14. thanks for your reply, i will do as advised.

    Posted 7 years ago on Thursday March 7, 2013 | Permalink
  15. Hi guys, I did try deactivating all other plugins and tried reverting to the Twenty Twelve theme and this doesn't change anything. The form still loads slow. I'm seeing this behavior on both my localhost and remote where all other pages load fast.

    Any other ideas or help you can provide?

    Posted 7 years ago on Thursday March 7, 2013 | Permalink
  16. David Peralty
    Administrator

    It shouldn't take 10-15 seconds per page. How many fields long is your form? How many fields per page? Are you doing anything special at all that could be the cause? I'm at a bit of a loss on how to help you with this currently as I can't re-create the error on my test installs.

    Posted 7 years ago on Friday March 8, 2013 | Permalink
  17. Hey David,

    I've got about about 20 fields total spread out over 4 pages, so not too long and not too many fields per page. I'm not doing anything special that I can think of. I've tried modifying a couple things to troubleshoot but can't seem to find a culprit.

    Want me to send you the form export so you can try it on your end?

    Thanks,
    - Jonah

    Posted 7 years ago on Friday March 8, 2013 | Permalink
  18. By the way, notifications don't seem to work on the forum here. I haven't received a notification since my first post...

    Posted 7 years ago on Friday March 8, 2013 | Permalink
  19. Ok, I think I've tracked the issue down. I systematically went through the form, removing field by field to see which field is bogging down the form. It's the radio/drop down pricing fields, of which I have two that I need in the form. If I remove these, the form/page load time goes down to essentially nothing. Having them in the form delays load time to about 10-15 seconds.

    Why would this be and is there any workaround you can think of to help with this?

    Again, let me know if you'd like an export of my form so you can test this out.

    Thanks for your help,
    Jonah

    Posted 7 years ago on Friday March 8, 2013 | Permalink
  20. This actually seems to be unrelated to the multi-page form too. The form loads very slowly with radio/drop down pricing fields either way. Again, I'm seeing this behavior locally and remotely. Any ideas?

    Thanks,
    Jonah

    Posted 7 years ago on Friday March 8, 2013 | Permalink
  21. Form submission is taking about 45 seconds too... what the heck is going on? Here is my multi page form: http://cl.ly/code/3P1F012c3U3f and here is the same form on one page: http://cl.ly/code/3N070r2O2Z2h

    Posted 7 years ago on Friday March 8, 2013 | Permalink
  22. David Peralty
    Administrator

    I'm going to bring your issue to the attention of the developers. Can you e-mail WordPress login details and list out exactly which form is having issues please? We may also need FTP details to track things down, but let's start with WordPress. My e-mail is peralty@rocketgenius.com

    Posted 7 years ago on Monday March 11, 2013 | Permalink