PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Not seeing value of a dropdown

  1. I've got forms that require the user choose faculty/staff/student from a dropdown. When I fill out the entire form correctly I get the error:

    This field is required. Please enter a value.

    I've attempted to process this form with every possible value selected with no luck.

    URL: http://web.saumag.edu/library/library-services/interlibrary-loan/book-request-form/

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  2. Update: in one of the affected forms I replaced the dropdown field with a multiple-choice field and it worked fine.

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  3. We'll check it out Shelley. I'll be in touch.

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  4. Hey Shelley, what version of Gravity Forms are you running?

    Also, try deleting that field entirely. Save the form. Edit the form again and re-add that field and then save.

    Let me know if that does the trick.

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  5. I'll try it (and I'm betting it'll work), but I'm concerned as to the cause. If I have to do this with any regularity across potentially dozens of forms it's going to get old fast.

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  6. How many forms is this happening on right now? Or is it just the one and you plan on adding more and are worried about it happening in the future...

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  7. It happened on the only 2 forms with dropdowns I had setup. They worked pre-upgrade, but I didn't test them afterwards.

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  8. What version of Gravity Forms is this install running?

    It sounds like you are running v1.1 and our v1.1.1 should have patched this issue. Our automatic upgrade log shows you are running v1.1 also.

    Let me know if you are running v1.1 or v1.1.1, you can see it on the plugin Settings page.

    Posted 10 years ago on Friday September 18, 2009 | Permalink
  9. Ok, the 1.1.1 upgrade seems to have fixed it. I didn't have an upgrade flag in my plugins display and I somehow missed any email that might have come through about the upgrade. Thx :)

    Posted 10 years ago on Friday September 18, 2009 | Permalink

This topic has been resolved and has been closed to new replies.