PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

reCAPTCHA problem

  1. idealists
    Member

    Running locally. I just installed reCaptcha to my contact form, and added the public/private keys to the GF settings.
    In firefox, the form page never loads, and I get the following errors:
    Error: Recaptcha is not defined
    Source File: http://localhost/mysite.com/contact-us
    Line: 0
    Error: RecaptchaState is not defined
    Source File: http://api.recaptcha.net/js/recaptcha.js
    Line: 451

    Any ideas?

    Thanks much!

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  2. It's hard to tell what the issue is without being able to access the site.

    It could be a plugin conflict with another plugin. It could be incorrect public and private keys. It could be a theme conflict.

    You will have to start with conflicts and double check to make sure your keys are 100% correct.

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  3. idealists
    Member

    Thanks Carl, can I email the link to you?
    What address?

    Cheers

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  4. idealists
    Member

    What email address can I send the link to?

    Posted 9 years ago on Thursday July 8, 2010 | Permalink
  5. You can send the information via our contact form and we'll be happy to check on it.

    Posted 9 years ago on Friday July 9, 2010 | Permalink
  6. idealists
    Member

    Hi Carl, get my email?
    Just asking cos I know I've had the odd email (send/receive) problems in the past.

    Posted 9 years ago on Saturday July 10, 2010 | Permalink
  7. Just a thought, are you using David's paging script on this form? He mentioned in his post that "It does not play nice with reCaptcha"

    http://forum.gravityhelp.com/topic/wizard-plugin-for-gravity-forms#post-6191

    That could be the source of your problem.

    Posted 9 years ago on Saturday July 10, 2010 | Permalink
  8. idealists
    Member

    Thanks so much, that was it, not sure why I missed that!

    You guys are great!

    Posted 9 years ago on Saturday July 10, 2010 | Permalink