PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

SSL, Https on Gravity form pages

  1. Hi,

    I purchased a GoDaddy SSL, or my client did for this website, http://valleyviewwinery.com/
    It seems that with Word Press, you may need a plugin-in to make things become secure? I primarily want the three Gravity forms to be secure. Please advise or send any recommendations to help get the the SSL applied to the Gravity forms if not the entire site.

    Thanks!

    Posted 11 years ago on Thursday December 30, 2010 | Permalink
  2. You can force SSL with modifications to your .htaccess file

    http://www.webmasterworld.com/apache/3507002.htm

    or as you mentioned, you can always use a plugin to force the https - something like this one.

    http://wordpress.org/extend/plugins/wordpress-https/

    Posted 11 years ago on Thursday December 30, 2010 | Permalink
  3. Thank you. This will allow me to force the https on just the form pages, yes? Where do add the mod rewrite code?

    Thanks, I'll get there, hopefully =)

    Posted 11 years ago on Thursday December 30, 2010 | Permalink
  4. You should have a .htaccess file in the root of your web directory. That's where you would add the mod rewrite rules. If you don't see the file there, you can contact your webhost to find out where to access it.

    Posted 11 years ago on Thursday December 30, 2010 | Permalink
  5. I have the same issue as kmk7. I have configured SSL in the server already and setup the authorize.net plugin in wordpress. The page is still unsecured.
    http://www.lihbc.org/about_lihbcdc/general-fund-donation/

    I did check "force SSL" in credit card section. After I refreshed the page, it said "An error occurred during a connection to http://www.lihbc.org.
    SSL received a record that exceeded the maximum permissible length.
    (Error code: ssl_error_rx_record_too_long).

    So I went back to uncheck it. And then I installed WordPress HTTPS (SSL) Plugin. It's even worse. I can't even login and gave me the same message as above. I have to go to the server to change the name of the plugin in order to deactivate. Then I can login to my site.
    What can I do to secure the donation page (gravity form) and change http to https? Is it necessary to change http to https?

    Posted 10 years ago on Wednesday April 18, 2012 | Permalink