PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

SSL Issue Blamed on Gravity Forms ??

  1. Cloudflare (www.cloudflare.com) has blamed the /wp-content/plugins/gravityforms/js/conditional_logic.js?ver=1.6.3.3.4. file from preventing a simple for site to display the red X in Google Chrome that is associated with insecure content. The site url is https://secure.gpscanadian.ca. Please advise asap, thanks!

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  2. David Peralty

    You might want to force HTTPS on all items called in your theme. Have a look at the following plugin:
    http://wordpress.org/extend/plugins/wordpress-https/

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  3. Hi David, I have tried that; however, it causes a redirect error I believe...any other solution?

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  4. Please see this image for error upon installation and activation of your recommend plugin: http://prntscr.com/9yaxe.

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  5. David Peralty

    I am not sure why you have a re-direct loop. There aren't any others that I know of that would make sure all the included files forced to use HTTPS. And you have to use HTTPS for files like the conditional logic JS file.

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  6. Yeah, me neither - that's why I posted here :-) So the conclusion is that Gravity Forms does not play friendly with Cloudflare SSL? (by the way, I think there's an issue with the email notification system for new posts. Seems to work the first time but not after several posts even though the "Subscribe to this Topic Via Email" box is checked. )

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  7. David Peralty

    If you can get the SSL plugin to not do a redirect loop then it would work fine. If you remove conditional logic, it will also probably work. You could also manually put in the links for Gravity Forms files and hard code them as https and remove them from being called by the plugin. There are options.

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  8. OK, i will remove the conditional logic and see if that makes Gravity Forms SSL compatible.

    Posted 10 years ago on Thursday May 31, 2012 | Permalink
  9. Hi Patrick,

    I am just about to do the same, Gravity Forms, HTTPS and Cloudflare.

    Any tips on your set up.

    I see you are using conditional logic on your form.

    Thanks,

    Mark

    Posted 10 years ago on Friday June 1, 2012 | Permalink
  10. I just installed the plugin (WordPress HTTPS) myself. I had to turn off the Gravity Forms "Force SSL" on the credit card field before the plugin would work.

    Posted 10 years ago on Saturday June 23, 2012 | Permalink
  11. Have you hard coded the httpS for gravity forms to play nice with Cloudflare?

    Mark

    Posted 10 years ago on Sunday June 24, 2012 | Permalink