PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Too much space in form containers.

  1. When I inspect elements it has multiple empty <p> tags I can't find to get rid of, and it looks like it may be causef by the following hidden fields. I just don't understand how or why they are taking up so much space. I am specifically using the Ultimatum Theme (from http://www.UltimatumTheme.com).

    It does seem to be on all Gravity Forms in this theme.

    Here is one of the pages I am having the issue:
    http://www.nwesource.com/WP/website-management-services/managed-web-hosting-for-wordpress/

    Here is how the trouble page looks with the same code in another theme:
    http://www.nwesource.com/website-management-services/managed-web-hosting-for-wordpress/

    Any help will be greatly appreciated.

    This is the HTML code with all of the hidden fields that seems to be causing an empty <p> for each:

    <div class="gform_footer top_label"> <input type="submit" id="gform_submit_button_5" class="button gform_button" value="Submit" tabindex="6"><input type="hidden" name="gform_ajax" value="form_id=5&title=1&description=1">
                <input type="hidden" class="gform_hidden" name="is_submit_5" value="1">
                <input type="hidden" class="gform_hidden" name="gform_submit" value="5">
                <input type="hidden" class="gform_hidden" name="gform_unique_id" value="506b489942307">
                <input type="hidden" class="gform_hidden" name="state_5" value="YToyOntpOjA7czo2OiJhOjA6e30iO2k6MTtzOjMyOiIwZTA1ZTk5NzZjOWRmMTExMzBlMmNhYjQ3YjI2NTIyNSI7fQ==">
                <input type="hidden" class="gform_hidden" name="gform_target_page_number_5" id="gform_target_page_number_5" value="0">
                <input type="hidden" class="gform_hidden" name="gform_source_page_number_5" id="gform_source_page_number_5" value="1">
                <input type="hidden" name="gform_field_values" value=""><p></p></div>
    Posted 7 years ago on Tuesday October 2, 2012 | Permalink
  2. The extraneous paragraph tags shouldn't be there. This appears to be a theme/plugin conflict of some sort where extra markup is being introduced. Do you still see the same markup when viewing the form in the preview page?

    The first thing we need to do is make sure you do not have a theme or plugin conflict. You can test for those by following these instructions http://rkt.gs/testing

    Posted 7 years ago on Tuesday October 2, 2012 | Permalink
  3. Don't think so. Looks like there are both empty P tags and
    at the end of every line = annoying. So I guess I will post on Ultimatum forums then right? :-)

    Thanks! Let me know if you think of anything else, or know of something that could be causing it other than the theme.

    Posted 7 years ago on Tuesday October 2, 2012 | Permalink
  4. Yeah, usually when we see extraneous markup it's something that the host theme is adding when the page is rendered. I'll poke around and see if I can replicate the issue but yeah, I would ask them as well and see if they have some function that could be causing the issue. The theme looks pretty complex so I'm sure there's a lot going on behind the scenes.

    Posted 7 years ago on Tuesday October 2, 2012 | Permalink
  5. Ultimatum is cool, it's a Drag and drop site builder and works pretty dang well. It has GUI support for custom post types, includes Mega Menu and more. The built in form builder isn't anywhere near Gravity of course... It works primarily by widgetizing almost everything.

    I'm ready to start testing Thesis 2.0 which sounds drag and droppable, but didn't sound like everything was in widgets. Both themes could be an opportunity for collaboration between you powerhouses :-) ...

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  6. So it turns out the resolution in Ultimatum is to use their [raw] shortcode [/raw] around the Gravity Forms shortcode.

    Thanks for your help, best of luck to you all...

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  7. David Peralty
    Administrator

    It isn't a good thing when you have to use a Raw shortcode around our shortcode, and you should ask them to rectify this in the future as they are changing how WordPress works and breaking things in a way they should try to avoid.

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  8. Can you tell me what issues, or types of issues you have experienced with using a raw shortcode around your own? I can communicate it in my forum post to them and also I need to know the severity - can I expect normal forms to work? or is it just advanced functionality that will be likely have issues?

    Thanks!

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  9. Please see this post from Carl Hancock which explains the problem in detail:
    http://www.gravityhelp.com/forums/topic/form-worked-for-a-while-and-then-disappeared#post-6394

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  10. Interesting. Although [raw] worked for me, [noformat] doesn't seem to work in my theme - is it supposed to be universal in WP? I don't see much on Google about it... thanks! I will make sure this resolution gets forwarded on to this theme maker as well, so let me know what's next or what to tell them...

    I was going to forward the link to them as well, but it is protected content so I will appreciate further assistance. Thanks!

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  11. Neither is universal. You could have this function in your theme with a shortcode called [dontbemessin] and then the [dontbemessin] shortcode would run the same function. The issue is not the name of the shortcode, it's how that function goes about making sure your input it not processed. The problem is, in the meantime, it messes with the processing of every other shortcode in WordPress.

    If you never used the [raw] shortcode functionality, remove that function from your theme. Then you can stop wrapping the Gravity Form shortcode in the [raw] shortcode.

    The problem is the addition of the functionality into WordPress, not the actual name of the shortcode. It's not included in WordPress at all. Some theme providers include this code in their themes.

    Posted 7 years ago on Wednesday October 3, 2012 | Permalink
  12. Hey! Since you guys are obviously the competent and responsible ones in this issue with Ultimatum, can you provide specific patching instructions, or any kind of workaround for Ultimatum, until they get their act together? Thanks!

    Posted 7 years ago on Tuesday October 30, 2012 | Permalink
  13. The work around is to wrap the [gravityforms] shortcode in the [raw] shortcode [/raw] - did you already try that?

    Complete instructions for fixing their code is beyond the support we can offer. Use the work around detailed above, or strip the offending code from the theme.

    Posted 7 years ago on Wednesday October 31, 2012 | Permalink
  14. Yeah, I already tried that.

    Any pointers to "the offending code" ?

    What would it probably look like?

    Thanks for any clues.

    Posted 7 years ago on Wednesday October 31, 2012 | Permalink
  15. If the raw shortcode did not work, you will have find the code which is reprocessing all the shortcodes. The code will look like some variant of this:
    http://www.wprecipes.com/disable-wordpress-automatic-formatting-on-posts-using-a-shortcode

    Find something in that code to search your theme for and you will probably find it. When you do, remove the function, and remove the associated shortcode, whatever that is in your theme.

    Posted 7 years ago on Wednesday October 31, 2012 | Permalink