PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Use Logged In User As Author

  1. I'm a little confused about something. I have a site that requires users to register before they can view the form. The form is on a page that is protected from non-registered users via S2 Member. The form is also only viewable when logged in.

    When I setup the form and made everything live, I went to my registration page and registered under another email address I own. I then logged into the site using my new alias for the site and made a submission on the new form. Everything worked perfectly. It automatically set the post author as my alias. Unfortunately, I've had to registered users log in and create a post using the same form on my site and both of them are being set as the admin user, rather than the logged in user.

    I have everything setup correctly, and did not change anything after I beta tested it, so I don't know why it isn't working. Any clues as to why this would be happening all of a sudden? thanks in advance.

    Posted 7 years ago on Sunday July 1, 2012 | Permalink
  2. Can you provide a link to your form please?

    Posted 7 years ago on Monday July 2, 2012 | Permalink
  3. What is your email Chris? I cannot share the link on this thread. My partner would be upset.

    Posted 7 years ago on Thursday July 5, 2012 | Permalink
  4. Just making sure - did you follow the steps shown here:
    http://gravitywiz.com/2012/04/25/set-registered-user-as-post-author/

    Posted 7 years ago on Thursday July 5, 2012 | Permalink
  5. Kev, if you still need help, please email chris@rockegenius.com - thanks

    Posted 7 years ago on Friday July 6, 2012 | Permalink
  6. @Rob: yup..tried that.

    @ Chris: email sent to you. Thanks for the assist.

    Posted 7 years ago on Monday July 9, 2012 | Permalink
  7. Kevin, I emailed you.

    Posted 7 years ago on Monday July 9, 2012 | Permalink
  8. @Chris: Just emailed you again. Still having some issues with this. The issue is a little more complex than I previously explained I believe. Sorry for not being clear enough earlier. My apologies.

    Posted 7 years ago on Friday July 13, 2012 | Permalink
  9. I have your email Kevin. I'll take a look at it tonight or over the weekend.

    Posted 7 years ago on Friday July 13, 2012 | Permalink
  10. Kev, I emailed you this evening with one suggestion.

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  11. I have just implemented your suggestion of setting them post to 'draft' instead of 'pending review'. I will update this thread for others in the next few days after some live testing is done.

    Thanks again Chris. I appreciate your help. GF Team is awesome.

    Posted 7 years ago on Tuesday July 17, 2012 | Permalink
  12. Thanks Kev. I received your email. Please let us know if it works. Thank you.

    Posted 7 years ago on Wednesday July 18, 2012 | Permalink
  13. Chris,

    So far so good. I'm just concerned, as the "pending review" option seemed to work for awhile also, so I'm just kind of "waiting to see" lol. As for now, it seems to work properly, I will update this thread if it stops working in the next couple of weeks.

    Thanks again for the assist. I appreciate it.

    Posted 6 years ago on Wednesday July 25, 2012 | Permalink