PLEASE NOTE: These forums are no longer utilized and are provided as an archive for informational purposes only. All support issues will be handled via email using our support ticket system. For more detailed information on this change, please see this blog post.

Version 1.6 Beta 2 Bug - Number Field

  1. When selecting Number Format, 'Select a Format' is repeated numerous times. And are there only supposed to be 2 choices?
    http://grab.by/aQrm

    WP 3.2.1

    Posted 10 years ago on Monday September 5, 2011 | Permalink
  2. I'm using 1.6beta2 and WordPress 3.2.1 as well and had a different experience. I have just two choices:

    9,999.99
    9.999,99

    I do some more tests and see what's up. Anything else unique about your situation? It could be a JavaScript conflict (from a plugin or even your theme) in the wp-admin...

    Posted 10 years ago on Tuesday September 6, 2011 | Permalink
  3. The "Select a format" option is displayed for fields that were created prior to 1.6, and therefore don't have a format specified. It was added to maintain backwards compatibility with older versions. I am not sure why you have more than one "Select a format", but I will look into why that could be happening. To solve your problem, select one of the available formats (9,999.99 or 9.999,00). When you do that, all your "Select a format" options will go away. If they don't, please let me know I will dig deeper.

    Posted 10 years ago on Tuesday September 6, 2011 | Permalink
  4. Hi Alex and Chris

    I think this could be caused by a conflicting script or some other problem on my local dev (XAMPP), because the extra 'Select a format' is gone now. And I did nothing except disabled some plugins....

    So let me look this over more on my end.

    If you are able to replicate the problem, please post here to let me know.

    Thanks

    Posted 10 years ago on Tuesday September 6, 2011 | Permalink
  5. I was finally able to replicate the problem. The problem is that the "Select a format" option is being added every time you expand the field editor. If you "Edit" your number field, then "Close" the editor and then "Edit" it again, you will see two "Select a format" options. If you reload the page, all the extra options are gone. I have fixed the issue locally and it will be out in the next release. This is not a critical fix, but if you would like to have it, please email me at alex@rocketgenius.com and I will send it your way.

    Posted 10 years ago on Tuesday September 6, 2011 | Permalink
  6. Hi Alex

    I'm just happy it's not on my end :)

    Thanks!

    Posted 10 years ago on Tuesday September 6, 2011 | Permalink

This topic has been resolved and has been closed to new replies.